Author Topic: drill grinding sound stops after first block  (Read 106 times)

d3x0r

  • Jr. Member
  • **
  • Posts: 69
    • View Profile
drill grinding sound stops after first block
« on: April 20, 2017, 10:57:28 am »
So when drilling, if I click and drill, there's a kinda buzzing/grinding sound for the drill.  If I continue to hold the button, that sound stops for the second block.  if I release and click again it re-starts.  (almost shouldn't stop really?)

when holding shift (to run?) the footstep sound stops; and move speed doesn't seem different (if there's supposed to be one)

(Windows 7)
« Last Edit: April 20, 2017, 11:01:24 am by d3x0r »

Enigma

  • Administrator
  • Newbie
  • *****
  • Posts: 46
    • View Profile
Re: drill grinding sound stops after first block
« Reply #1 on: April 22, 2017, 04:03:45 am »
Thanks for this report and interesting reflections,

The drilling sound was really annoying when mining repeatedly for a long time. That's why we decided to stop it after collecting one block for saving our ears ;). Yes, it could be taken as a bug, so we agree it's not the perfect idea. We left it as is because it is comfortable. Maybe we'll find something better someday...

There is no "running" mode in Blackvoxel. The idea behind this choice is : faster = vehicles. If the player could run, the vehicles would be less usefull.

We tough about an optional running mode as a power. But this will depend on our futur choices about game balancing. Nothing decided yet.

Shift in Blackvoxel activate the "No Fall" mode and the "Caps Lock" key locks this mode on.

We choose this key because it is near the "WASD" keys and easier to maintain for a long time than the CTRL key.

In this mode, the player is supposed to walk cautiously, so the feet won't hit the ground hard enough to make a footstep sound.


rajdakin

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: drill grinding sound stops after first block
« Reply #2 on: May 12, 2017, 06:01:49 pm »
The first "bug" can be converted into an option: when enabled, it stops the sound after the first block, but not if the option is disabled.

The second "bug" may be resolved by changing the sound of the footstep (maybe less loud?).

Enigma

  • Administrator
  • Newbie
  • *****
  • Posts: 46
    • View Profile
Re: drill grinding sound stops after first block
« Reply #3 on: May 13, 2017, 10:15:59 am »
The first "bug" can be converted into an option: when enabled, it stops the sound after the first block, but not if the option is disabled.

The second "bug" may be resolved by changing the sound of the footstep (maybe less loud?).

Hi, Rajdakin and Welcome to the Blackvoxel forum. :)

Yes, we think these are good ideas for making it better. :)

The Blackvoxel Team

Ps: About your message on github, as the private messaging system is disabled because of some spammer issues, we sent you an email address on your email.