Author Topic: The v1.21 bug report thread  (Read 11043 times)

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: The v1.21 bug report thread
« Reply #15 on: October 12, 2013, 01:13:35 am »
Hello Toupie,

Thanks. Oh. And I forgot one small bug I've noticed.

When a programmable computer places the last of a voxeltype in its inventory, that voxeltyp still is visible in the computers inventory, but with a quantity of 0. Manually moving another voxeltype into to that inventory slot clears it.

And don't take these bug reports as complaints. I only want to try and help make Blackvoxel better since I see some great potential in it.

That's added in the list.

We are pleased that users report bugs because it helps to improve the game. We know that it takes time to you to make bug reports, so we thank you for that.

The Blackvoxel Team
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #16 on: October 13, 2013, 03:14:56 pm »
Tried to make my own textures and failed miserably. Maybe I did something wrong?
I didn't make them transparent. Some faces are missing qompletely and the qolors are wrong. Green looks purple and red looks blue. Submitted the
The first 2 images depict qubes with the RGB texture and the others are with black texture with some red on it. The last 7 images were kinda qool so I just uploaded them even though they might not be that useful :>
I tried both replacing textures in the texture folder and using the UserTexture object and got the same result.

Textures:

(I qan't uplod the red paint texture, too big for attachment and postimage.org doesn't accept it )
Supporter since 2013-09-08 17:16 GMT+1

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #17 on: October 13, 2013, 05:23:26 pm »
I noticed that postimage.org uses PNG qompression on images.
http://speedy.sh/BdmFx/voxeltexture-1.bmp
http://speedy.sh/rEfpz/voxeltexture-1.bmp
I used A8R8G8B8 with the latest GIMP. Don't see what I qould've done to sqrew it up but it's the textures that have problems also. The file you linked to http://www.blackvoxel.com/dm_download.php?file=4 works.
My textures look qorrect in an image viewer...
Supporter since 2013-09-08 17:16 GMT+1

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: The v1.21 bug report thread
« Reply #18 on: October 13, 2013, 08:58:25 pm »
Looked at your bmp and everything appeared good to me right except it lacked an alpha channel on the second one.

I tried to do a step by step explication for your second image to work. I downloaded the latest Gimp version on Windows to be sure using the same name for the menu (the ubuntu 12.04 version I use is slightly outdated) and.... just discovered the same issue as you.

Crawling on the web, found a lot of complaints with the latest versions of Gimp and BMP. Even with the new "compatibility mode" checkbox it didn't worked .

So I will have to look in it what they did with the file format on the latest Gimp versions.

For interim solution until we found a way to fix it would be to get the 2.6.12 version of Gimp. I just tested it OK on Windows : http://sourceforge.net/projects/gimp-win/files/GIMP%20%2B%20GTK%2B%20%28stable%20release%29/GIMP%202.6.12%20%2B%20GTK%2B%202.16.6/

All images must have an alpha channel (Layer -> Transparency -> Add Alpha channel), event the images that don't use transparency. And the inventory image should be done (use the same as the center). For now, it isn't used but will be in the future.

For images using transparency like glass, it must have a voxelinfo. It's not needed for regular voxels.

The Blackvoxel Team
« Last Edit: October 13, 2013, 09:01:01 pm by olive »
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #19 on: October 13, 2013, 10:28:25 pm »
Thank you now it works :)
Supporter since 2013-09-08 17:16 GMT+1

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: The v1.21 bug report thread
« Reply #20 on: October 13, 2013, 10:36:34 pm »
We look forward to seeing the result!
 :)
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #21 on: October 16, 2013, 11:32:02 pm »
Qreated a new world to try some stuff out and gave myself 0xffff ffff of some items and 0xffff of some others and picking stuff up with my tool and with qomputers and maybe pushing and pulling voxels has qaused the qlient to qrash several times now. Have fun debugging ;)
Ask me about details if you need any. I don't really know why it qrashes though

Code: [Select]
Assertion failed: _gc_chain==NULL, file /home/laurent/workspace/blackvoxel/src/sc_Squirrel3/squirrel/sqstate.cpp, line 204

This application has requested the Runtime to terminate it in an unusual way.
Please contact the application's support team for more information.

And another qrash (I might be pushing and pulling to/from empty space):
Code: [Select]
AN ERROR HAS OCCURED [indexing bool with string]

CALLSTACK
*FUNCTION [main()] C:\Users\Qon\Documents\Blackvoxel\Universes\2\Scripts\Squirrel\6.nut line [6]
*FUNCTION [qbits_save()] C:\Users\Qon\Documents\Blackvoxel\Universes\2\Scripts\Squirrel\6.nut line [14]
*FUNCTION [Voxel_Step()] C:\Users\Qon\Documents\Blackvoxel\Universes\2\Scripts\Squirrel\6.nut line [51]

LOCALS
[vargv] ARRAY
[this] true
[n] -117167720
[this] TABLE
[n] 0
[this] TABLE

I have no function qalled main and line 14 is
Code: [Select]
n--
Also qompressors seems to dupliqate when I pick them with the qomputer and the items that I try to pull from the qompressor stays inside it. And when I place a qompressor again the items are still inside! :Q

It's entirely possible that I'm doing something odd... I'm a bit tired q:
« Last Edit: October 16, 2013, 11:43:31 pm by Qon »
Supporter since 2013-09-08 17:16 GMT+1

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #22 on: October 20, 2013, 02:22:03 pm »
I picked up some infeqted voxels and some smiley monsters and played a bit with them.
The infeqted voxels were kind of unprediqtable, sometimes (or some places where) when I spawned them they didn't affect nearby blocks and turned to red liquid almost immediatly. Other times they started spreading endlessly and it took a looong time before any of the blocks finally turned to red liquid. That didn't stop its spreading since it qontinued to spread many times faster than it turned into liquid. My whole world was infeqted. The whole blue enter qube and, the water and white blackrocks around it, all the green blocks and the lava around that and then the big tree forest. At that time only a few blocks in the center had turned into liquid and everything else as far as I qould see was orange.

Good thing I had a backup of my world :o
Supporter since 2013-09-08 17:16 GMT+1

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: The v1.21 bug report thread
« Reply #23 on: October 21, 2013, 01:32:44 am »
I picked up some infeqted voxels and some smiley monsters and played a bit with them.
The infeqted voxels were kind of unprediqtable, sometimes (or some places where) when I spawned them they didn't affect nearby blocks and turned to red liquid almost immediatly. Other times they started spreading endlessly and it took a looong time before any of the blocks finally turned to red liquid. That didn't stop its spreading since it qontinued to spread many times faster than it turned into liquid. My whole world was infeqted. The whole blue enter qube and, the water and white blackrocks around it, all the green blocks and the lava around that and then the big tree forest. At that time only a few blocks in the center had turned into liquid and everything else as far as I qould see was orange.

Good thing I had a backup of my world :o

;D

It seems that these spreading voxels can be very unfriendly when used outside the sequence initiated by the "smiley" voxel  ???.

In the normal case sequence, the spread time depends on of how many "smiley" voxel are disturbed at the same time.

The Blackvoxel Team
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #24 on: October 21, 2013, 01:51:34 am »
Same thing happened when I started the reaqtion by placing a smiley.
I tried to pick it up immediatly after placing it and succeeded but sometimes my inventory qount didn't go up.
Supporter since 2013-09-08 17:16 GMT+1

Toupie

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Re: The v1.21 bug report thread
« Reply #25 on: October 21, 2013, 03:38:10 pm »

PullVoxelFrom() will fail if the programmable robot does not have any internal storage slots without an voxel type, even if some of the slots have zero quantity. This combined with the bug that leaves the voxel type in the slots when you empty them makes for a game breaking bug. Once the programmable robot has filled all it's slots it can't ever pick up anything more until you manually fix those left over zero quantity voxels.

A workaround is to make sure you always have at least one slot that is completely empty, no quantity and no voxel type. But that reduces the programmable robots internal storage to 19 instead of 20.

Toupie

  • Jr. Member
  • **
  • Posts: 62
    • View Profile
Re: The v1.21 bug report thread
« Reply #26 on: October 21, 2013, 03:46:43 pm »
Infinite death loop.

If you dig a deep hole at location x:0 z:0 you will end up in an infinite death loop if you die since you always respawn at x:0 y:0 z:0.

Either put a voxel below the player spawn point on respawn or scan for a safe place to respawn the player. (The later is probably prefered, or you could be stranded on a single voxel without anything in your inventory to build your way out.)

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #27 on: October 21, 2013, 09:00:35 pm »
Atomiq Qompressor has id 49 but the manual says 100!
Supporter since 2013-09-08 17:16 GMT+1

Qon

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: The v1.21 bug report thread
« Reply #28 on: October 21, 2013, 10:00:51 pm »
http://www.blackvoxel.com/view.php?node=1476
Siliqon Wafer needs a blackrock blue to be made but the recipe in the manual doesn't mention it.
Supporter since 2013-09-08 17:16 GMT+1

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: The v1.21 bug report thread
« Reply #29 on: October 22, 2013, 12:11:17 am »
Infinite death loop.

If you dig a deep hole at location x:0 z:0 you will end up in an infinite death loop if you die since you always respawn at x:0 y:0 z:0.

Either put a voxel below the player spawn point on respawn or scan for a safe place to respawn the player. (The later is probably prefered, or you could be stranded on a single voxel without anything in your inventory to build your way out.)

Thanks. We will fix that  ;)
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook