Author Topic: Linux Mint install issues.  (Read 2629 times)

Shade53

  • Newbie
  • *
  • Posts: 2
    • View Profile
Linux Mint install issues.
« on: January 29, 2014, 04:11:39 am »
I got the game and it works well on windows(aside the beta stuffs) but I decided to try and install it on my Linux Mint 16 x64 OS on another partition in my drive. When I open the blackvoxel_1.30_amd64.deb it returns a status of missing libGLEW.so.1.6. However I already have the newest libGLEW installed.

Tried searching google for help, but nothing is better than asking the person that made it.

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: Linux Mint install issues.
« Reply #1 on: January 30, 2014, 01:54:45 am »
I got the game and it works well on windows(aside the beta stuffs) but I decided to try and install it on my Linux Mint 16 x64 OS on another partition in my drive. When I open the blackvoxel_1.30_amd64.deb it returns a status of missing libGLEW.so.1.6. However I already have the newest libGLEW installed.

Tried searching google for help, but nothing is better than asking the person that made it.

Hi,

We apologize for your problem.

As indicated on our website, at this time,  Blackvoxel is compatible with the 12.04(LTS) version of Ubuntu.

Unfortunately, it would be impossible for us to support all versions of each Linux distributions, so for the time, we have chosen to support only Ubuntu Long Term Support versions (LTS). We haven't yet worked on extension to other distributions or non LTS versions of Ubuntu.

I'm afraid there is no easy immediate workaround for your problem apart using the 12.04 LTS version of Ubuntu or something based on this. In most cases, different distributions would requires specific compilation/packaging and strong testing to be sure it would work with it. I can't recommend any dirty hack that will likely broke your system if you don't have very strong knowledge of what you are doing.

The problem with your distribution might be the following : the last version of mint is typically based on a recent "non LTS" version of Ubuntu (that we don't support). This version provides more recent libraries which isn't compatible with the Ubuntu 12.04 version of Blackvoxel.

Stay tuned for the next version of Ubuntu LTS 14.04 because we should plan a version for it. The next Mint that will be based on it should be compatible (but not officially supported).

In the future, it is possible we might extend compatibility to some other distributions, but I can't tell you more at this time.

The Blackvoxel Team
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook

shadowwraith

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Linux Mint install issues.
« Reply #2 on: May 23, 2014, 04:18:43 pm »
i am also having trouble installing Blackvoxel on Mint 16, i have tried both the 12.04 and 14.04 versions to no avail, it appears that libglew1.6 was removed from the ubuntu repositories in 2012, the current version of libglew is libglew1.8, but the game explicitly requires libglew1.6

olive

  • Administrator
  • Full Member
  • *****
  • Posts: 149
    • View Profile
Re: Linux Mint install issues.
« Reply #3 on: May 24, 2014, 02:02:37 am »
i am also having trouble installing Blackvoxel on Mint 16, i have tried both the 12.04 and 14.04 versions to no avail, it appears that libglew1.6 was removed from the ubuntu repositories in 2012, the current version of libglew is libglew1.8, but the game explicitly requires libglew1.6

Thanks for your report.

The provided binary packages are compiled individually on the targeted distributions with the library versions used on it. It's why these packages are tied to a particular distribution and version.

Mint 16 is based on Ubuntu 13.10. The Ubuntu 12.04 versions uses libglew version 1.6 and the 14.04 versions uses libglew 1.10.... and the debian version uses libglew 1.7.

So, Iím afraid none of these packages could work on Mint 16. But it should work for Mint 17 with the Ubuntu 14.04 version.

Also, with the move to free software, there is now a way to run Blackvoxel on unsupported distribution : compiling from source code.

It's not as simple as installing the packages, but on linux it's can be done with a few steps. You can find a tutorial here

As several users want Mint, we think to add it for the next versions. But I have decided to do for you now a special version of the Beta 33 64 bits for Mint 16. (Tell us if you need 32 bits.)

You can download it here : blackvoxel_1.33beta_amd64.deb

Remember it is a beta version. So report any problem with it.

The Blackvoxel Team
Blackvoxel is now a free software!  Visit the official website http://www.blackvoxel.com
Follow us on twitter | Follow us on facebook